import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+(?: +\\w+)+(?=\\s*:\\s*B)";
final String string = "Ronald Mayr: A\n"
+ "Bell Kassulke : B\n"
+ "Simon Loidl: B\n\n"
+ "Надо сгенерировать список только тех, кто получил оценку В:\n"
+ "Bell Kassulke\n"
+ "Simon Loidl";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}