const regex = /\w+(?: +\w+)+(?=\s*:\s*B)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w+(?: +\\w+)+(?=\\s*:\\s*B)', 'g')
const str = `Ronald Mayr: A
Bell Kassulke : B
Simon Loidl: B
Надо сгенерировать список только тех, кто получил оценку В:
Bell Kassulke
Simon Loidl`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}