#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)[^<]*<(.*)>.*"
Local $sString = "--------------------------3cbec9ce8f05" & @CRLF & _
"Content-Disposition: form-data; name="owServerData"; filename="details.xml"" & @CRLF & _
"Content-Type: text/plain" & @CRLF & _
"" & @CRLF & _
"<?xml version="1.0" encoding="UTF-8"?>" & @CRLF & _
"<Devices-Detail-Response xmlns="http://www.example.com" " & @CRLF & _
" // Rest omitted" & @CRLF & _
"</Devices-Detail-Response>" & @CRLF & _
"------------------------------3cbec9ce8f05--"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")