package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)[^<]*<(.*)>.*`)
var str = `--------------------------3cbec9ce8f05
Content-Disposition: form-data; name="owServerData"; filename="details.xml"
Content-Type: text/plain
<?xml version="1.0" encoding="UTF-8"?>
<Devices-Detail-Response xmlns="http://www.example.com"
// Rest omitted
</Devices-Detail-Response>
------------------------------3cbec9ce8f05--`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}