// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)[^<]*<(.*)>.*").unwrap();
let string = "--------------------------3cbec9ce8f05
Content-Disposition: form-data; name=\"owServerData\"; filename=\"details.xml\"
Content-Type: text/plain
<?xml version=\"1.0\" encoding=\"UTF-8\"?>
<Devices-Detail-Response xmlns=\"http://www.example.com\"
// Rest omitted
</Devices-Detail-Response>
------------------------------3cbec9ce8f05--";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}