const regex = /[^<]*<(.*)>.*/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^<]*<(.*)>.*', 's')
const str = `--------------------------3cbec9ce8f05
Content-Disposition: form-data; name="owServerData"; filename="details.xml"
Content-Type: text/plain
<?xml version="1.0" encoding="UTF-8"?>
<Devices-Detail-Response xmlns="http://www.example.com"
// Rest omitted
</Devices-Detail-Response>
------------------------------3cbec9ce8f05--`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}