using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^<]*<(.*)>.*";
string input = @"--------------------------3cbec9ce8f05
Content-Disposition: form-data; name=""owServerData""; filename=""details.xml""
Content-Type: text/plain
<?xml version=""1.0"" encoding=""UTF-8""?>
<Devices-Detail-Response xmlns=""http://www.example.com""
// Rest omitted
</Devices-Detail-Response>
------------------------------3cbec9ce8f05--";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}