#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=Past 30 Days ).+(?![^-])"
Local $sString = "Internet-Devices Used to Access Internet Past 30 Days [Desktop Computer-Owned by Self]" & @CRLF & _
"" & @CRLF & _
"Internet-Devices Used to Access Internet Past 30 Days [Tablet-Owned by Other HH Member] " & @CRLF & _
"Internet-Devices Used to Access Internet Past 30 Days [Laptop Computer-Made Available by Your Employer]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")