using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Past 30 Days ).+(?![^-])";
string input = @"Internet-Devices Used to Access Internet Past 30 Days [Desktop Computer-Owned by Self]
Internet-Devices Used to Access Internet Past 30 Days [Tablet-Owned by Other HH Member]
Internet-Devices Used to Access Internet Past 30 Days [Laptop Computer-Made Available by Your Employer]";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}