import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Past 30 Days ).+(?![^-])";
final String string = "Internet-Devices Used to Access Internet Past 30 Days [Desktop Computer-Owned by Self]\n\n"
+ "Internet-Devices Used to Access Internet Past 30 Days [Tablet-Owned by Other HH Member] \n"
+ "Internet-Devices Used to Access Internet Past 30 Days [Laptop Computer-Made Available by Your Employer]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}