const regex = /(?<=Past 30 Days ).+(?![^-])/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Past 30 Days ).+(?![^-])', '')
const str = `Internet-Devices Used to Access Internet Past 30 Days [Desktop Computer-Owned by Self]
Internet-Devices Used to Access Internet Past 30 Days [Tablet-Owned by Other HH Member]
Internet-Devices Used to Access Internet Past 30 Days [Laptop Computer-Made Available by Your Employer]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}