re = /(?<=Past 30 Days ).+(?![^-])/
str = 'Internet-Devices Used to Access Internet Past 30 Days [Desktop Computer-Owned by Self]
Internet-Devices Used to Access Internet Past 30 Days [Tablet-Owned by Other HH Member]
Internet-Devices Used to Access Internet Past 30 Days [Laptop Computer-Made Available by Your Employer]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end