#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)!(.+?\.\w{3,4})\|width=(\d+),height=(\d+)!"
Local $sString = "!image.jpg|width=1920,height=1080!" & @CRLF & _
"!1892904.jpg|width=1020,height=1000!" & @CRLF & _
"!34778 (cfec0e19-cd14-426d-8ff3-441f419a5335).jpg|width=1280,height=720!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")