const regex = /!(.+?\.\w{3,4})\|width=(\d+),height=(\d+)!/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('!(.+?\\.\\w{3,4})\\|width=(\\d+),height=(\\d+)!', 'gi')
const str = `!image.jpg|width=1920,height=1080!
!1892904.jpg|width=1020,height=1000!
!34778 (cfec0e19-cd14-426d-8ff3-441f419a5335).jpg|width=1280,height=720!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}