// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)!(.+?\.\w{3,4})\|width=(\d+),height=(\d+)!").unwrap();
let string = "!image.jpg|width=1920,height=1080!
!1892904.jpg|width=1020,height=1000!
!34778 (cfec0e19-cd14-426d-8ff3-441f419a5335).jpg|width=1280,height=720!";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}