re = /!(.+?\.\w{3,4})\|width=(\d+),height=(\d+)!/i
str = '!image.jpg|width=1920,height=1080!
!1892904.jpg|width=1020,height=1000!
!34778 (cfec0e19-cd14-426d-8ff3-441f419a5335).jpg|width=1280,height=720!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end