using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"!(.+?\.\w{3,4})\|width=(\d+),height=(\d+)!";
string input = @"!image.jpg|width=1920,height=1080!
!1892904.jpg|width=1020,height=1000!
!34778 (cfec0e19-cd14-426d-8ff3-441f419a5335).jpg|width=1280,height=720!";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}