using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\s_]+_[^\s_]+\K_(?=\S*\.jpg$)";
string input = @"123_456_789.jpg
3210_5325_aa.jpg
54321-0888_555_1111.jpg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}