import re
regex = re.compile(r"^[^\s_]+_[^\s_]+\K_(?=\S*\.jpg$)", flags=re.MULTILINE)
test_str = ("123_456_789.jpg\n"
"3210_5325_aa.jpg\n"
"54321-0888_555_1111.jpg")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")