use strict;
my $str = '123_456_789.jpg
3210_5325_aa.jpg
54321-0888_555_1111.jpg';
my $regex = qr/^[^\s_]+_[^\s_]+\K_(?=\S*\.jpg$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}