re = /^[^\s_]+_[^\s_]+\K_(?=\S*\.jpg$)/m
str = '123_456_789.jpg
3210_5325_aa.jpg
54321-0888_555_1111.jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end