# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/->\K[a-zA-Z]{5,15}\['[a-zA-Z]{5,15}']/{$0}/gm;t' <<< "$this->returnData['status']"