re = /->\K[a-zA-Z]{5,15}\['[a-zA-Z]{5,15}']/m
str = '$this->returnData[\'status\']'
subst = '{$0}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result