import Foundation
let pattern = #"->\K[a-zA-Z]{5,15}\['[a-zA-Z]{5,15}']"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"$this->returnData['status']"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"{$0}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)