const regex = /->\K[a-zA-Z]{5,15}\['[a-zA-Z]{5,15}']/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('->\\K[a-zA-Z]{5,15}\\[\'[a-zA-Z]{5,15}\']', 'gm')
const str = `\$this->returnData['status']`;
const subst = `{$0}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);