use strict;
my $str = '$this->returnData[\'status\']';
my $regex = qr/->\K[a-zA-Z]{5,15}\['[a-zA-Z]{5,15}']/mp;
my $subst = '{$0}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";