#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)->\K[^[\n]+\['[^\n']+']"
Local $sString = "$this->returnData['status']"
Local $sSubst = "{$0}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)