re = /->\K[^[\n]+\['[^\n']+']/m
str = '$this->returnData[\'status\']'
subst = '{$0}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result