$re = '/->\K[^[\n]+\[\'[^\n\']+\']/m';
$str = '$this->returnData[\'status\']';
$subst = "{$0}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;