const regex = /->\K[^[\n]+\['[^\n']+']/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('->\\K[^[\\n]+\\[\'[^\\n\']+\']', 'gm')
const str = `\$this->returnData['status']`;
const subst = `{$0}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);