using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"->\K[^[\n]+\['[^\n']+']";
string substitution = @"{$0}";
string input = @"$this->returnData['status']";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}