using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[a-zA-Z0-9]{6,8}|[a-zA-Z0-9]{10,12})$";
string input = @"thisisatest
thisisate
thisis
thisisatestforalongstring";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}