$re = '/^(?:[a-zA-Z0-9]{6,8}|[a-zA-Z0-9]{10,12})$/m';
$str = 'thisisatest
thisisate
thisis
thisisatestforalongstring';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);