using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b((?:\d{4}\ ){3}\d{4}|\d{16})\b";
string input = @"1234 4567 1234 4567
1234456712344567
12344567 1234 4567
12344567123445678";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}