package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b((?:\d{4}\ ){3}\d{4}|\d{16})\b`)
var str = `1234 4567 1234 4567
1234456712344567
12344567 1234 4567
12344567123445678`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}