re = /\b((?:\d{4}\ ){3}\d{4}|\d{16})\b/m
str = '1234 4567 1234 4567
1234456712344567
12344567 1234 4567
12344567123445678'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end