$re = '/\b((?:\d{4}\ ){3}\d{4}|\d{16})\b/m';
$str = '1234 4567 1234 4567
1234456712344567
12344567 1234 4567
12344567123445678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);