// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b((?:\d{4}\ ){3}\d{4}|\d{16})\b").unwrap();
let string = "1234 4567 1234 4567
1234456712344567
12344567 1234 4567
12344567123445678";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}