const regex = /(?:\s+?).+?\s+(S\/\d+)\s+(\d+)\s+(S\/\d+\.\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\s+?).+?\\s+(S\\\/\\d+)\\s+(\\d+)\\s+(S\\\/\\d+\\.\\d+)', 'gm')
const str = `Detalle\\n Unidad\\n Cantidad\\n Total\\n Triple Insomnio Especial S/37 1 S/37.90 Insomnio Especial S/21 2 S/23.12 *Tipo de papa:* - Papa Amarilla Tumbay S/0.00\\n *Adicional :* - Quesp cheddar S/0.00\\n *Agrega Bebida:* - Fanta 400 ml S/0.00\\n *Salsas:* - Mayonesa S/0.00\\n - Ketchup S/0.00\\n - Golf S/0.00\\n - Guacamole S/0.00\\n - Ají S/0.00\\n - Tártara S/0.00\\n - Mayo-aji S/0.00\\n `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}