re = /(?:\s+?).+?\s+(S\/\d+)\s+(\d+)\s+(S\/\d+\.\d+)/m
str = 'Detalle\\n Unidad\\n Cantidad\\n Total\\n Triple Insomnio Especial S/37 1 S/37.90 Insomnio Especial S/21 2 S/23.12 *Tipo de papa:* - Papa Amarilla Tumbay S/0.00\\n *Adicional :* - Quesp cheddar S/0.00\\n *Agrega Bebida:* - Fanta 400 ml S/0.00\\n *Salsas:* - Mayonesa S/0.00\\n - Ketchup S/0.00\\n - Golf S/0.00\\n - Guacamole S/0.00\\n - Ají S/0.00\\n - Tártara S/0.00\\n - Mayo-aji S/0.00\\n '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end