# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\s+?).+?\s+(S\/\d+)\s+(\d+)\s+(S\/\d+\.\d+)"
test_str = "Detalle\\n Unidad\\n Cantidad\\n Total\\n Triple Insomnio Especial S/37 1 S/37.90 Insomnio Especial S/21 2 S/23.12 *Tipo de papa:* - Papa Amarilla Tumbay S/0.00\\n *Adicional :* - Quesp cheddar S/0.00\\n *Agrega Bebida:* - Fanta 400 ml S/0.00\\n *Salsas:* - Mayonesa S/0.00\\n - Ketchup S/0.00\\n - Golf S/0.00\\n - Guacamole S/0.00\\n - Ají S/0.00\\n - Tártara S/0.00\\n - Mayo-aji S/0.00\\n "
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.