// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\s+?).+?\s+(S\/\d+)\s+(\d+)\s+(S\/\d+\.\d+)").unwrap();
let string = "Detalle\\n Unidad\\n Cantidad\\n Total\\n Triple Insomnio Especial S/37 1 S/37.90 Insomnio Especial S/21 2 S/23.12 *Tipo de papa:* - Papa Amarilla Tumbay S/0.00\\n *Adicional :* - Quesp cheddar S/0.00\\n *Agrega Bebida:* - Fanta 400 ml S/0.00\\n *Salsas:* - Mayonesa S/0.00\\n - Ketchup S/0.00\\n - Golf S/0.00\\n - Guacamole S/0.00\\n - Ají S/0.00\\n - Tártara S/0.00\\n - Mayo-aji S/0.00\\n ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}