use strict;
my $str = 'Detalle\\n Unidad\\n Cantidad\\n Total\\n Triple Insomnio Especial S/37 1 S/37.90 Insomnio Especial S/21 2 S/23.12 *Tipo de papa:* - Papa Amarilla Tumbay S/0.00\\n *Adicional :* - Quesp cheddar S/0.00\\n *Agrega Bebida:* - Fanta 400 ml S/0.00\\n *Salsas:* - Mayonesa S/0.00\\n - Ketchup S/0.00\\n - Golf S/0.00\\n - Guacamole S/0.00\\n - Ají S/0.00\\n - Tártara S/0.00\\n - Mayo-aji S/0.00\\n ';
my $regex = qr/(?:\s+?).+?\s+(S\/\d+)\s+(\d+)\s+(S\/\d+\.\d+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}