#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^>.*$"
Local $sString = "test >11 years old" & @CRLF & _
">twin brother dies" & @CRLF & _
">parents dont let me go to his funeral or tell me where it is" & @CRLF & _
">tells me it would be innapropriate to be there as it could confuse people " & @CRLF & _
"i dided"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")