const regex = /^>.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^>.*$', 'gm')
const str = `test >11 years old
>twin brother dies
>parents dont let me go to his funeral or tell me where it is
>tells me it would be innapropriate to be there as it could confuse people
i dided`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}