// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^>.*$").unwrap();
let string = "test >11 years old
>twin brother dies
>parents dont let me go to his funeral or tell me where it is
>tells me it would be innapropriate to be there as it could confuse people
i dided";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}