import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^>.*$";
final String string = "test >11 years old\n"
+ ">twin brother dies\n"
+ ">parents dont let me go to his funeral or tell me where it is\n"
+ ">tells me it would be innapropriate to be there as it could confuse people \n"
+ "i dided";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}