# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w+)\h*([^\w\s](?:\h+[^\w\s])*)\h*/$1 $2 /mg;t' <<< "test! one.two .three; four, five . six. .seven"