#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\w+)\h*([^\w\s](?:\h+[^\w\s])*)\h*"
Local $sString = "test! one.two .three; four, five . six. .seven"
Local $sSubst = "$1 $2 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)