re = /(\w+)\h*([^\w\s](?:\h+[^\w\s])*)\h*/m
str = 'test! one.two .three; four, five . six. .seven'
subst = '$1 $2 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result